Jump to content
Lord Vetka

Version issues

Recommended Posts

Since coming to this site I have happily returned to version 1.3.1

 

The problem I'm finding out is going back and working on a map in the editor that was made in version 1.4.1

 

The first problem I encountered is troops crossing my river, I have 2 villages blocked by the river for your own use, I fixed the problem by redoing the water.

 

But soon found a new problem, when I start the game, none of the troops that I placed for the AI castles are on the towers or walls or keep.

 

I had to completely delete all of the enemy troops then delete all of the walls, towers, and the keep. Then redo every thing before the map would work properly.

 

I was planning on using that map for the contest, so I will be posting it at a later date when I've done final tests and write the story....

 

Just making a few points about using different versions.

 

Lord Vetka

Share this post


Link to post
Share on other sites

This appears to be a very common, and most frustrating issue with the game versions.

 

The first problem I encountered is troops crossing my river

 

Troops crossing rivers is another common issue, however, not necessarily caused by game versions:

 

http://www.strongholdnation.co.uk/article/20-rivers-menu#other

 

Have you used this icon at all?

 

editor_159.png

 

This will allow you to make water that your troops can walk on, if you click on it once, then place water. NOTE: If you use this way instead of our tutorial's way, then troops can also walk into other places that they shouldn't be able to, like in the middle of forests.

 

There will probably be some way to overcome it, but it will be similar to the Map Unlocker and run on Java. Unfortunately I have had no experience with that.

 

I actually have attempted to locate the changes in files, but have been unable to find any massive changes as of yet. But of course with the .dll files being unreadable (virtually) it's quite hard.

 

Just a note: One glitch I have noticed is that any buildings (including keeps) will let units go straight through them like they don't even exist. And with the keep, The Lord will not be able to get inside.


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

The river runs from the top to the bottom of the map and I used cross able water at my castle to get to the 2 villages, the problem I was having is all of the water was cross able, my troops would walk up the river to the villages instead of the nice road I made for them, I replaced most of the water and it's all good now.

 

The building glitch started with 1.4, they had to make 1.4.1 to fix the problem, 1.4 was made for multi player.

 

I think what I will do is reinstall SH2 because I'm still having issues with it, I don't think I cleared every thing when I uninstalled it, I will look deeper.

 

Then I think I will start over with new maps, some of my older maps have been completed and don't need adjustments so I can post those maps to the site. The map I'm working on can be posted when it's done.

 

 

Well that was strange, I clicked the submit button and got an error, then I could not do anything so I copied my reply and made a new reply, clicked submit with no problem, now there are 2 messages.

Edited by Lord Vetka

Share this post


Link to post
Share on other sites

That same problem with the water happened on @bradley0095's file Protecting Your Lands 2v4, and he made his with version 1.4.

 

I would be surprised if not everything cleared though. You could make sure by removing the /My Documents/Stronghold 2/ folder. I'm not actually sure whether that does get deleted when you uninstall it, I certainly haven't noticed it go before. There are also some files inside c:/ProgramData/ I think, and again, I'm not sure whether that gets deleted. Let me know when you find it out though :)

 

That will be good, I'm glad you can post some completely finished ones again. Also, I'm planning on making the new deadline for the contest the 20/03/2014, just to let you know.

 

Don't worry, I was attempting to change the way emails get sent, but it wasn't working so I changed it back. You only just did it before I changed it back mind, as in seconds. I've removed the other message, no problem. :)

Edited by Lord_Chris

Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

I think some files are in the windows config file, I did remove the SH2 folders and the /My docs/ folders.

 

I will look for the C:program data file and see if there is something there.

 

This time I will remove the game and then run my registry cleaner and file cleaners and see if they can remove unused files after removing SH2.

 

With the version problems my map definitely needs more time before it would be ready for the contest, a couple of weeks should be enough time.

 

Thanks for clearing the message!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...