Jump to content
ajm102

Gameranger just launches to main menu

Recommended Posts

Hello and Happy Holidays,

 

I am having an issues connecting to my friends gameranger game in stronghold 2, I join the lobby and the game starts but instead of sending me to the stronghold game lobby it sends me to the main menu. I have tried everything, I don't understand what the issue is. My other friend was having the same issue and he ran it in XP compatibility mode to fix it, but that didn't work for me. I am using windows 8 and have stronghold 2 version 1.4.1. Any help would be appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

Welcome to the site, @ajm102!

 

Kicking you out of the game and to the main menu is usually a sign of different versions, as myself and @bradley0095 have also experienced this issue. We spent a couple of hours trying to figure it out, and eventually that was the cause.

 

A couple of questions:

 

Is the version they are using 1.4.1? I would guess from what you've told us there, it's 1.4. This is bad not only because it's an unstable version, but also because of the massive differences. Your friends can get the latest patch from our downloads section if that is the version they are using.

 

When you're playing online, all players must be using the same version of the game. Try joining in a different order. The other issue of course, is that some firewall is blocking the connection, this announcement should be of use if that's the case.

 

Keep us posted, have a wonderful Christmas :)


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

Thanks for the quick response,

 

I looked into the issue a bit more and it seems that I have version 1.4.1 but with gameranger it runs version 1.4, I have the steam version so all should be up to date. Any idea how to force gameranger to run the most up to date version?

Share this post


Link to post
Share on other sites

It is running 1.4 though, which I think is strange. Although everyone is running 1.4 with gameranger so that shouldn't be the issue, anyone have any other ideas why I just get booted to main menu?

Share this post


Link to post
Share on other sites

I may be going over already stated theories but here's these:

 

Same game ranger version

Same stronghold version

Low ping

 

That's all the simple ones im not too familiar with game ranger so im sure the other members could help with some other ideas :) hope you fix it!


"Gofyn wyf am galon hapus, calon onest, calon l?n."

Share this post


Link to post
Share on other sites
if you have 1.4.1, it should be the only reason GR could possibly run.

 

I think you can run Crusader through game ranger with two different versions as well, wasn't that what happened to us that time before I uninstalled it? GameRanger doesn't shouldn't care what game version you have, it's only running the connection stuff more than patches.etc. Maybe that's part of the reason why so many people have problems with it...

 

Any idea how to force gameranger to run the most up to date version?

 

I would exit your game, and restart steam completely. Doing so *should* force steam to download any updates available. However, if it hasn't done so already, then there is likely a problem. You would probably be better off verifying the integrity of your steam cache first. To do this:

 

Go to your Steam games library. Right click on the title, then click "Properties" on the pop-up panel. A new window with several tabs should appear. Click "Local Files" then "Verify integrity of game cache." This should scan, repair, and (if needed) replace all files associated with the game

 

I'm completely unaware as to whether or not steam can have the patch added manually, but you may want to download the patch from the link I posted above and see if it will let you install it on your system or not. At best, the problem will be fixed. At worst, you'll just need to reinstall the game (which may work as a benefit actually, if it's not patching up correctly.)

 

The patch is written into the registry, so the update should be fine. However, as I said before, I'm unsure of the behaviour of steam games and how they affect SH2 running through it.


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites
I think you can run Crusader through game ranger with two different versions as well, wasn't that what happened to us that time before I uninstalled it? GameRanger doesn't shouldn't care what game version you have, it's only running the connection stuff more than patches.etc. Maybe that's part of the reason why so many people have problems with it...

You are right, only I assumed that, if he has two versions of Stronghold 2, he should be aware of that. I mean, one needs to put some effort to install two versions of any game. And, yeah, GameRanger doesn't care about almost anything. I am able to play Stronghold Europe using GameRanger by "tricking" GR to think it is Crusader actually. :)

Share this post


Link to post
Share on other sites

Thanks for all the feedback,

 

All people just installed the game on the day we tried it so they should a be the same version. What I mean by game ranger is running 1.4 is that when I look into the info about my games it says stronghold 2 is version 1.4. I have tried to manually install the patch but steam won't allow it. Does anyone play stronghold 2 using windows 8? That is the only difference I have been able to find between the systems that work and the majority of the ones that don't. Although it might not be because one of the people have no problems when they run in win xp compatibility mode. Anything else I should try?

Share this post


Link to post
Share on other sites

I have tried compatibility mode but it didn't solve the problem. Any other possibilities, I have tried everything I can think of.

Share this post


Link to post
Share on other sites

I did suggest you should try to verify the integrity of your steam cache in my earlier post, in case something is missing or corrupt. That may help :)

 

What you play on the operating system is of no importance to it, providing the hardware/software specifications match of course. And if you're able to play the game fine, then it should be. Are you playing offline or with an internet connection to steam? Starting steam in offline mode will not allow it to send any updates to you, because an internet connection is required.


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

Steam is online, I have tried to verify game integrity, it didn't solve the issue. Everything I am using is standard, just windows 8, a good processor and gpu, steam is online and game ranger is up to date. I'm not sure why I am having a problem. Does anyone know anything that could be causing this? It's probably something really obscure at this point.

Share this post


Link to post
Share on other sites

I have kind of been following the thread, the one thing I have seen you guys not mention is the fact that the game does not like different versions, you guys talked about Gameranger not caring, but the game does.

 

Probably has nothing to do with it but a suggestion anyway.

 

When you start SH2 it should ask if you want to upgrade if you are not upgraded to 1.4.1, all players should be at the same version.

Share this post


Link to post
Share on other sites

Hm, also, you didn't tell what version your friends have? Maybe you are fine - maybe you have 1.4.1, but your friends may have 1.4. Did you try to play with anyone else?

 

I have 1.4.1, if you want, I could come online at some moment, so you could try it with me? You would only need to tell me when - we could meat at 21:00 for example, Central European timezone (Belgrade/Berlin).

Share this post


Link to post
Share on other sites
When you start SH2 it should ask if you want to upgrade if you are not upgraded to 1.4.1, all players should be at the same version.

 

Unless your firewall is blocking the internet connection of course....

 

If it's showing in the game as 1.4.1, then it's an issue with game ranger or online play because it's what happens in the game that matters, I suggest you try the following steps (in order)

 

  1. Try clearing your DNS cache. I doubt it will work, but it may be worth a try and will benefit you regardless.
  2. Completely reinstall the game, making sure that patches are downloaded automatically from steam. Something must be stopping the patch from downloading. Hopefully that will resolve the issue. If the patches don't download automatically from a clean install, then clearly it's due to a network error, which means we're closer to solving it.


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

I am pretty sure they are all the same version, we are using steam in online mode, so they kind of have to be. I will double check when I get the chance though, just to be sure.

Share this post


Link to post
Share on other sites

ok then. Try to either allow the program through your firewall using the link I provided in my above post, or (much better) turn off your firewall whilst you test.

 

We all know that turning your firewall off is not recommended, as always, preform a scan before doing so - however, providing it is not off for long there will not be a reason to worry.

 

Also make sure you have no spyware or viruses on your computer (check with updated anti-spyware and antivirus programs).


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

Firewall seems like the most likely cause here. I host many servers for different games with the firewall on but every so often I have to turn it off as it randomly blocks ports at times. So as Lord_Chris suggested, test your game with the firewall off, no harm should be done in 10 minutes assuming you only go on Gameranger.


"Gofyn wyf am galon hapus, calon onest, calon l?n."

Share this post


Link to post
Share on other sites

Thanks for the suggestion.

 

We tried turning all of our firewalls off and it still didn't work, I don't get it. Any thing else I could try, I really want to play but this is proving to be quite difficult to do.

Share this post


Link to post
Share on other sites

I think you should contact steam. Tell them you've cleared your DNS cache, tell them that the game is fine when you're playing in single player, but when you go to multiplayer it's stating the game is patch 1.4. It may also be a good idea to give them a link to this thread so they can see what else you've tried, but since the game is ran through the steam client and that appears to be what's causing the issue, it's probably the best place to go. It's also possible that there is some kind of compatibility issue that steam/firefly/game ranger don't yet know about with steam & game ranger. After all - it's only been using Game Ranger for a few months, they may not even be aware a steam version of the game exists.

 

You can submit a steam support request via the following link: https://support.steampowered.com/newticket.php


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

I'm busy at the moment. :(

 

But if you would like to post a new topic in the gaming events forum and set a specific time, I'll see what I can do (and I'm sure other members will too)


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...