Jump to content
Mathew Steel

SHC2 Scripting

Recommended Posts

Requesting map scripters to fix an invasion on my map. Everything is set up including markers but the invasion seems to sit idle. The attacking force will travel to the invasion point and set up a siege camp but then remain to hold ground. They do not attack me (the player) and I can't seem to find a fix.

 

I need people who can fix the problem, you will be given credit for the help in the map download. If anyone knows how please let me know with a contact email etc. and I will be sure to send you the map!


"Gofyn wyf am galon hapus, calon onest, calon l?n."

Share this post


Link to post
Share on other sites

Hey, sent me the file and I will take a look. Maybe I can find and solve the problem.


TeamMuppet.eu

Share this post


Link to post
Share on other sites

You forgot the set "Pathings". Go into the "Marker" topic and pathing and set them where your markers are. I created 3 chains and it is working for me now.

 

I noticed:

- you forgot to block the water with path blocking tool.

- the carter post at grey castle is not working (mark it, then on the right side click "Objects" and choose what it should deliver)

- the markers for the siege camp (target) are to near to the red castle (catapults get instant destroyed)

- the blue spawnpoint needs to be a bit right else the Lord will spawn on a strange spot and will be inside the keept

 

Game crashed at the end. Maybe it was my fault but better check this :)

Overall nice idea but I just won this map with shields, arab archers and swordman. Maybe think of some balancing so there is need for the stone.

Edited by Micha!

TeamMuppet.eu

Share this post


Link to post
Share on other sites

Those are quite a lot of things I didn't notice thank you for that! Very grateful :)


"Gofyn wyf am galon hapus, calon onest, calon l?n."

Share this post


Link to post
Share on other sites

I created a small map with some stuff to do. Additional I added markers and created a simple invasion.

You can download the map here: http://ul.to/qfc9lgm8 (place it in example: C:\Users\Username\Documents\Stronghold Crusader 2\Maps)

 

The goal is to find out how to create an invasion on "mission" map type. They are just standing around like Mathew said.

Placing markers and paths are enough for a "skirmish" invasion but it seems like "mission" is different from this one.

Edited by Micha!

TeamMuppet.eu

Share this post


Link to post
Share on other sites

There's obviously some way of setting the target, just seems it's not as simple as before. I'll keep trying to get to the source of the problem.


"Gofyn wyf am galon hapus, calon onest, calon l?n."

Share this post


Link to post
Share on other sites

It seems like a problem alright, I put a ticket into FireFly about it and they did not help at all, I guess we are on our own:-(

 

From what I can tell is there are no instructions built in for the invasions, they do not know what to do, if you use the skirmish then the AI gives the invasions direction, but in the invasion scenario, the trigger is "start invasion" so the troops move to the designated flags but there is nothing to direct them to invade, to "finish the invasion".

 

Micha!, the map you made does have the final invasion sort of working, they did invade but not all of the troops, the siege equipment did what it was supposed to do.

 

I think I will make another test map and systematically try one thing at a time, I don't know what else to do!

Share this post


Link to post
Share on other sites

I did this too. I placed the stuff and made it so that everything should be used. The horse archers are meant to patrol, some invasion troops should "harass troops form up" meaning shooting from the hill to my castle.

Edited by Micha!

TeamMuppet.eu

Share this post


Link to post
Share on other sites

Yes I played around with your map in the editor and in game, the horse archers just stood there, even the cat that you sent up the hill did not fire on the estate, the troops came down and retook the village, only because my range units were firing on them.

 

I have made several test maps and this time it will be one thing at a time, maybe there is just something we are missing, the invasions work great if the map is skirmish. it makes me a bit squeamish:-)

Share this post


Link to post
Share on other sites

It feels like the KI is turned off if it is set to mission. Maybe it's not possible to do a invasion.


TeamMuppet.eu

Share this post


Link to post
Share on other sites
Maybe it's not possible to do a invasion.

 

I never really used the SH3 editor (apart from a couple of failed trail maps) but was this feature implemented in there?


Quote

The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post


Link to post
Share on other sites

Yes I did make one map for SH3 and it was a war scenario and worked fine.

 

I have found something that might make the invasions work, I did manage to have a siege invasion work, then made a change now it does not work but I have not had a chance to try again, I will today.

 

What I did was to place 3 markers, an entry point a move to point and a target point, the target point is in front of the keep, the move to point is outside the castle and range of towers. then I put a siege marker next to the move to marker, the enemy would come in and do nothing, siege just stood at the entry marker.

 

Then I looked in the marker tab and went to the third tab and it's pathing/double click and you get a chain/ double click the chain and you get a number 1 marker, I placed the marker at the entry marker then clicked the chain again and got a number 2 marker with green lines to the first marker, I put this one by the go to marker, then I clicked again and got a number 3 marker that I put by the keep marker.

 

I saved and tested the setup, now the siege came in at the entry marker and proceeded to attack my castle, including the cross bows I included with the siege, so I went back into the editor and deleted the siege marker and tried again but now it would not work.

 

I think the key might be in the path markers, I noticed in the editor when I saved it asked if the path markers were set, and always it was a red NO, this time it was a green yes, the path markers seem to have an effect, give it a try, I will be doing more testing!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...