Jump to content

Aieditor Won't Open

Recommended Posts

I've run the AIEditor before on my old computer. I have a new one now (Win10/64bit) and am getting into this game again. There was no JAVA on this computer, so I downloaded the most recent version. When I start the AIEditor it runs for a split second (A flicker of a black panel in fact) and that's it. There's like 15 or so applications listed in the Java folder. Most of the apps have Java Platform in their title, so I'm not sure which one to pick, or if I should be selecting something else.

Any help would be greatly appreciated.

Thank you in advance!

Edited by Hockeymask

Share this post

Link to post
Share on other sites

Hi @Hockeymask, welcome to the Nation!

Are you sure you've downloaded the correct Java version? Can you let me know the version number and type that you've downloaded? Some for example are for server-side code or other things, so it may not be the correct version you've downloaded- I understand this can get a bit complicated.

The flip side to this also is that the AI Editor is a very old program. It's possible that it does not work on the very latest version of Java because of some compatibility change. I don't really think this is the case, because I downloaded Java again just in May, and it has worked perfectly for me on my machine. However, because I don't have any access to the source code of this program, I really can't say other than my own experience, from which it has worked.

If you've installed Java correctly, Windows should automatically determine that the AI Editor is a Java file and not need to manually open anything, but just double click on the editor file itself. I assume this is what's happening, that you're trying to open it with Java?


The fields have eyes, and the woods have ears.

⁠— Geoffrey Chaucer, The Canterbury Tales: The Knight's Tale

Useful Articles

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Topics

    • Map Editor Open/Close

      It seems to me that the map editor isn't working 100%. Whenever I want to close a map and open a new one, the only thing I can do is close the application, re-open it, then load the other map. This can be very frustrating, especially when I need to look at the other map for certain techniques etc.   If I am doing something wrong, please let me know :)

      in Stronghold Crusader 2

  • Create New...